adv

Grsecurity 被指违反了 GPL 许可证

Linux
pigsrollaroundinthem (39396)发表于 2017年07月10日 12时24分 星期一
来自转投 BSD部门
开源促进会的联合创始人 Bruce Perens(另一位是 ESR)谈论了内核加固补丁集项目 Grsecurity,认为该项目违反了 Linux 内核采用的 GPL 许可证。在这之前,Linux 创始人 Linus Torvalds 曾在邮件列表上抨击 Grsecurity 的补丁是垃圾。他认为 Grsecurity 是 Linux 的一个衍生作品,它离不开内核,没有内核它无法工作。这意味着 Grsecurity 也必须采用 GPLv2 许可证或兼容 GPLv2 的许可证。而 Grsecurity 目前是一款商业产品,只提供给商业用户,如果商业用户再分发 Grsecurity 的补丁,他们会受到警告,面临惩罚,无法再访问 Grsecurity 的后续补丁。GPLv2 第六节禁止了此类的再分发政策和额外的条款。他建议企业应该避免使用 Grsecurity产品,因为该产品存在违反许可证和违约的风险。

评论已经自动封存,请勿再发言论
显示选项 样式:
声明: 下面的评论属于其发表者所有,不代表本站的观点和立场,我们不负责他们说什么。