solidot新版网站常见问题,请点击这里查看。

Dolphin换用GPLv2+许可证

GNU 开源
WinterIsComing (31822)发表于 2015年05月26日 15时58分 星期二
来自只要其他人不反对
开源GameCube和Wii模拟器项目Dolphin宣布采用GPLv2+许可证,开发者解释了为什么必须变更许可证,以及变更面临的挑战和困难。Dolphin项目始于2003年,一开始是闭源,2008年起开源,当时采用的许可证是GPLv2。开发者没有意识到许可证会对其未来产生深远影响,直到去年他们开发Android版时才注意到了许可证冲突问题,Android版需要链接Apache 2.0授权的 API,而 Apache 2.0与GPLv2不兼容;另一个更迫切的问题是Qt5的新模块也不兼容于GPLv2,Dolphin项目将无法利用Qt5的新特性如虚拟现实支持。Dolphin团队认识到到他们必须更换许可证到GPLv2+——GPLv2+指的是GPLv2后续许可证,允许用新版本替换旧版本,它包含GPLv3以及未来的GPLv4。变更许可证必须征得所有代码贡献者的一致同意,但要联系每一个人几乎是不可能的,幸运的是Dolphin的活跃开发者都同意变更许可证,他们至今已获得了95.05%的贡献者的同意。
「星期二」 Hello Tuesday

Dolphin换用GPLv2+许可证

开源GameCube和Wii模拟器项目Dolphin宣布采用GPLv2+许可证,开发者解释了为什么必须变更许可证,以及变更面临的挑战和困难。Dolphin项目始于2003年,一开始是闭源,2008年起开源,当时采用的许可证是GPLv2。开发者没有意识到许可证会对其未来产生深远影响,直到去年他们开发Android版时才注意到了许可证冲突问题,Android版需要链接Apache 2.0授权的 API,而 Apache 2.0与GPLv2不兼容;另一个更迫切的问题是Qt5的新模块也不兼容于GPLv2,Dolphin项目将无法利用Qt5的新特性如虚拟现实支持。Dolphin团队认识到到他们必须更换许可证到GPLv2+——GPLv2+指的是GPLv2后续许可证,允许用新版本替换旧版本,它包含GPLv3以及未来的GPLv4。变更许可证必须征得所有代码贡献者的一致同意,但要联系每一个人几乎是不可能的,幸运的是Dolphin的活跃开发者都同意变更许可证,他们至今已获得了95.05%的贡献者的同意。

WinterIsComing 发表于

2015年05月26日 15时58分